R-金融网(www.r-gate.net)分享每日股票行情和全面的金融知识!

资金诊断副图指标 源码 通达信 贴图

R金融网 股票学校 2020-06-25 10:30:40 11
R-金融网(www.r-gate.net)提示:您正在查看的是:资金诊断副图指标 源码 通达信 贴图


ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//小筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//小股民套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);{//小股民警戒}
ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
{神秘黑洞}
STICKLINE(REF(ZSHTL,1)>90 AND ZSHTL<90,ZSHTL,0,4,0),COLOR9966FF;
{小股民套牢筹码}
STICKLINE(C>0,ZSHTL,ZZLKP,0,0),COLOREEEEEE;
{小股民筹码警戒}
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,1,0),COLORAAAAAA;
{主力控盘筹码}
STICKLINE(C>0,ZZLKP,0,3,0),COLORBLUE;
{铸顶风险区}
STICKLINE(ZZLKP>75,ZZLKP,0,3,0),COLORFFFFFF;
{顶部:(ZZLKP>75),COLORFFFFFF;}
{主力筹码警戒}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,3,0),COLORRED;
{筑底散兵坑}
STICKLINE(ZSHTL>=90,ZZLKP,0,3,0),COLORYELLOW;
{底部:(ZSHTL>=90),COLOR66FFCC;}
{筹码总量上升}
{IF(ZCMZL,ZCMZL>REF(ZCMZL,1),0),COLOR0066FF,LINETHICK0;}
{增量资金}
{//------【数值显示】}
散户套牢系数:INTPART(ZSHTL),NODRAW;
主力控盘系数:INTPART(ZZLKP),COLORCYAN,NODRAW;
资金流入强度:ZJLRQD,NODRAW;
{☆精确风险}
{【参数定义】}
RSV:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
K1:=SMA(RSV,10,1);
D1:=SMA(K1,5,1);
KK:=INTPART(K1);
DD:=INTPART(D1);
TFXXS:=KK+DD;{//变异KD风险系数}
TGLD:=MOD(TFXXS,10);{//踏浪停概率点}
TGLXS:=(TFXXS-REF(TFXXS,1))*10;{//变异KD乖离系数}
TYCFX:=TFXXS+TGLXS;{//变异KD预测风险}
乖离系数:TGLXS,NODRAW,COLORGREEN;
{【图解模板】}
{级别拐点}
{乖离系数}
STICKLINE(TGLXS>0,150,150+TGLXS,3,0),COLOR000088;
STICKLINE(TGLXS>0,150,150+TGLXS,2.5,0),COLOR000099;
STICKLINE(TGLXS>0,150,150+TGLXS,2,0),COLOR0000AA;
STICKLINE(TGLXS>0,150,150+TGLXS,1.5,0),COLOR0000BB;
{STICKLINE(TGLXS>0,100,100+TGLXS,1.2,0),COLOR0000CC;}
STICKLINE(TGLXS>0,150,150+TGLXS,1.0,0),COLOR0000DD;
{STICKLINE(TGLXS>0,100,100+TGLXS,0.8,0),COLOR0000EE;}
STICKLINE(TGLXS>0,150,150+TGLXS,0.5,0),COLOR0000FF;{//红柱}
STICKLINE(TGLXS<0,150,150+TGLXS,3,0),COLOR008800;
{STICKLINE(TGLXS<0,100,100+TGLXS,2.8,0),COLOR009900;}
STICKLINE(TGLXS<0,150,150+TGLXS,2.5,0),COLOR00AA00;
STICKLINE(TGLXS<0,150,150+TGLXS,2,0),COLOR00BB00;
{STICKLINE(TGLXS<0,100,100+TGLXS,1.8,0),COLOR00CC00;}
STICKLINE(TGLXS<0,150,150+TGLXS,1.5,0),COLOR00DD00;
{STICKLINE(TGLXS<0,100,100+TGLXS,1.2,0),COLOR00EE00;}
STICKLINE(TGLXS<0,150,150+TGLXS,1,0),COLOR00FF00;{//绿柱}
STICKLINE(TGLXS=0 AND REF(TGLXS,1)>=0,150,150+TGLXS,8,0),COLORRED;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)<0,150,150+TGLXS,8,0),COLORGREEN;
{【数值显示】}
风险系数:TFXXS,LINETHICK2,COLORYELLOW;
预测风险:TYCFX,LINETHICK1,COLORCYAN;
市场筹码总量:ZCMZL,COLORGREEN,LINETHICK1;
上市:FINANCE(42)/10000,NODRAW,COLORYELLOW;
STICKLINE(TGLXS>0 AND 100+TGLXS<TYCFX AND 100+REF(TGLXS,1)>=REF(TYCFX,1),0,(100+ABS(TGLXS)),0,0),COLORYELLOW;
STICKLINE(TGLXS<0 AND 100+TGLXS>=TYCFX AND 100+REF(TGLXS,1)<REF(TYCFX,1),0,(100+ABS(TGLXS)),0,0),COLORYELLOW;
T1:=CONST( ZCMZL>REF(ZCMZL,1) AND DKB=1);
T2:=CONST( ZCMZL>REF(ZCMZL,1) AND DKB=0);
T3:=CONST( ZCMZL=REF(ZCMZL,1));
T4:=CONST( ZCMZL<REF(ZCMZL,1) AND DKB=1);
T5:=CONST( ZCMZL<REF(ZCMZL,1) AND DKB=0);
T6:=CONST(TFXXS<=50 );
T7:=CONST(TFXXS>=160 );
T8:=CONST(TFXXS>50 AND TFXXS<160 AND TFXXS>=REF(TFXXS,1) AND TFXXS<=100 );
T9:=CONST( TFXXS>50 AND TFXXS<160 AND TFXXS>=REF(TFXXS,1) AND TFXXS>100);
T10:=CONST(TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1) AND TFXXS>100 );
T11:=CONST(TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1) AND TFXXS<=100 );
T12:=CONST( ZSHTL>90 );
T13:=CONST( ZZLKP>75 );
T14:=CONST(CROSS(ZCMZL,ZZLJJ) AND ZZLKP>ZZLJJ AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1) );
T15:=CONST(CROSS(ZCMZL,ZZLKP) AND ZZLKP>ZZLJJ AND ZZLKP<ZSHTL AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1) );
T16:=CONST( CROSS(ZCMZL,ZSHTL) AND ZSHTL>ZZLKP AND ZCMZL>REF(ZCMZL,1));
T17:=CONST( CROSS(ZCMZL,100) AND ZCMZL>REF(ZCMZL,1));
T18:=CONST(REF(ZSHTL,1)>90 AND ZSHTL<90 );
TS1:=IF(T1=1,0+0.03,0);
TS2:=IF(T2=1,TS1+0.03,TS1);
TS3:=IF(T3=1,TS2+0.03,TS2);
TS4:=IF(T4=1,TS3+0.03,TS3);
TS5:=IF(T5=1,TS4+0.03,TS4);
TS6:=IF(T6=1,0+0.73,0);
TS7:=IF(T7=1,TS6+0.03,TS6);
TS8:=IF(T8=1,TS7+0.03,TS7);
TS9:=IF(T9=1,TS8+0.03,TS8);
TS10:=IF(T10=1,TS9+0.03,TS9);
TS11:=IF(T11=1,TS10+0.03,TS10);
TS12:=IF(T12,0+0.03,0);
TS13:=IF(T13=1,TS12+0.03,TS12);
TS14:=IF(T14=1,TS13+0.03,TS13);
TS15:=IF(T15=1,TS14+0.03,TS14);
TS16:=IF(T16=1,TS15+0.03,TS15);
TS17:=IF(T17=1,TS16+0.03,TS16);
TS18:=IF(T8=1,TS17+0.03,TS17);
DRAWTEXT_FIX(T1,0.58,TS1,0,'★主力动向监控:主力增仓'),COLORRED;
DRAWTEXT_FIX(T2,0.58,TS2,0,'★主力动向监控:主力减仓'),COLORMAGENTA;
DRAWTEXT_FIX(T3,0.58,TS3,0,'★主力动向监控:多空平衡'),COLORGRAY;
DRAWTEXT_FIX(T4,0.58,TS4,0,'★主力动向监控:主力回补'),COLORFF9933;
DRAWTEXT_FIX(T5,0.58,TS5,0,'★主力动向监控:主力出逃'),COLORGREEN;
DRAWTEXT_FIX(T6,0.78,TS6,0,'★操作风险提示:买入风险'),COLORYELLOW;
DRAWTEXT_FIX(T7,0.78,TS7,0,'★操作风险提示:卖出风险'),COLORCYAN;
DRAWTEXT_FIX(T8,0.78,TS8,0,'★操作风险提示:追涨弈'),COLORRED;
DRAWTEXT_FIX(T9,0.78,TS9,0,'★操作风险提示:稳健持股'),COLORMAGENTA;
DRAWTEXT_FIX(T10,0.76,TS10,0,'★操作风险提示:盘跌减仓'),COLORWHITE;
DRAWTEXT_FIX(T11,0.76,TS11,0,'★操作风险提示:杀跌空仓'),COLORGREEN;
DRAWTEXT_FIX(T12,0.36,TS12,0,'☆特别信号提示:筑底散兵坑 '),COLOR66FFCC;
DRAWTEXT_FIX(T13,0.36,TS13,0,'☆特别信号提示:铸顶风险区'),COLORCYAN;
DRAWTEXT_FIX(T14,0.36,TS14,0,'☆特别信号提示:穿越主力 '),COLORRED;
DRAWTEXT_FIX(T15,0.36,TS15,0,'☆特别信号提示:穿越主力 '),COLORYELLOW;
DRAWTEXT_FIX(T16,0.36,TS16,0,'☆特别信号提示:穿越散户 '),COLORGREEN;
DRAWTEXT_FIX(T17,0.36,TS17,0,'☆特别信号提示:全盘穿越 '),COLOR3399FF;
DRAWTEXT_FIX(T18,0.36,TS18,0,'☆特别信号提示:神秘黑洞 '),COLOR9966FF;
叉:IF(REF(TFXXS,1)<REF(ZCMZL,1) AND TFXXS>ZCMZL,50,0),LINETHICK2,COLORCYAN;


多头:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60) AND MA(C,5)>REF(MA(C,5),1);
突破前高:=HHV(HIGH,20)=HHV(C,1) AND VOL>0 AND BARSCOUNT(CLOSE)>=20;
A1:=CROSS(MA(C,5),MA(C,10));
A2:=CROSS(MACD.DIF,MACD.DEA);
A3:=DYNAINFO(4)/DYNAINFO(3)<=1.03;
均价:=DYNAINFO(11)*(1+0.021);
ST:=IF(NAMELIKE('ST') OR NAMELIKE('*ST'),0,1);
金牛:DYNAINFO(11)>DYNAINFO(3) AND IF(DYNAINFO(7)>均价,1,0)AND 多头 AND 突破前高 AND A1 AND A2 AND ST;


A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
黑马:CROSS(趋势线,0)AND 黑马线<40,(HIGH* 0.97);

AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
老鼠仓:FF1,(LOW* 0.99);


AA:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1);
VARAA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
低2:=IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL);
HHM:=HHV(MACD.MACD*100,200);
LLM:=LLV(MACD.MACD*100,200);
M5:=MA(C,5);M10:=MA(C,10);M20:=MA(C,20);M60:=MA(C,60);
D3:=MIN(MIN(M5,M10),M20)>M60;
XGT:=BARSLAST(AA AND HHM<60 AND LLM>-55);
D6:=BARSSINCEN(MIN(MIN(M5,M10),M20)>M60,XGT+1);
XGX:=CROSS((XGT=0 AND D3) OR D6=0,0.5);
TJX:=COUNT(XGX,30)=2 AND XGX;
H300:=HHVBARS(DIF,300);
AL:=BOLL.UB;
TQ:=BARSLAST(CROSS(AL>=REF(AL,1),0.5));
E25:=EXPMA(C,25);
ZF:=EVERY(RANGE(C/REF(C,1),0.97,1.05),TQ+1);
ZFF:=(HHV(H,TQ+1)-LLV(L,TQ+1))/LLV(L,TQ+1)*100;
TJQ:=EVERY(MAX(C,O)/AL<1.02 ,TQ+1);
XL:=(ATAN((E25/REF(E25,TQ)-1)*100)*180/3.1415926);
TJ1Q:=CROSS(DIF>=REF(DIF,H300),0.5) AND ZFF<17 AND ZF AND TJQ;
起程:=TJ1Q AND XL>75;
TJ1L:=REF(CROSS(MA(C,5),C),1) AND CROSS(C,MA(C,5));
TJ2L:=REF(CROSS(MA(C,10),C),1) AND CROSS(C,MA(C,10));
TJ3L:=REF(CROSS(MA(C,20),C),1) AND CROSS(C,MA(C,20));
TJ4L:=TJ1L OR TJ2L OR TJ3L;
TJ5L:=REF(C,2)/REF(C,1)>=1.045 AND REF(C,1)<REF(O,1) AND C/REF(C,1)>1.09 AND C=H AND TJ4L;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线1:=EMA(KKC,50);
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*9;
KCCC3:=中线/长线1<1+0.01*20;
大牛:=KAAA3 AND KBBB3 AND KCCC3 AND TJ5L;
{VARAA:=LLV(LOW,5);}
VARBA:=HHV(HIGH,5);
确:=EMA((CLOSE-VARAA)/(VARBA-VARAA)*100,4);
信号:确>REF(确,1) AND DIF>DEA AND ( 大牛 OR 起程 OR TJX OR (CCI<=100 AND L<=低2)),COLORFF00FF;


R金融网股票学校直达:http://www.r-gate.net/xuexiao/gupiaoxuexiao/

R金融网基金学校直达:http://www.r-gate.net/xuexiao/jijinxuexiao/

R金融网外汇学校直达:http://www.r-gate.net/xuexiao/waihuixuexiao/

R金融网理财学校直达:http://www.r-gate.net/xuexiao/licaixuexiao/

R金融网保险学校直达:http://www.r-gate.net/xuexiao/baoxianxuexiao/

分享:

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.r-gate.net/xuexiao/gupiaoxuexiao/159256.html

郑重声明:R金融网发布此信息的目的在于传播更多信息,与本站立场无关。R金融网不保证该信息(包含但不限于文字、视频、音频、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。

(11)
打赏 微信扫一扫
« 上一篇 2020年06月25日 10:25:58
下一篇 » 2020年06月25日 10:30:44