R-金融网(www.r-gate.net)分享每日股票行情和全面的金融知识!

分享自用金拐点主图指标 源码 通达信 贴图

R金融网 股票学校 2020-06-25 10:30:44 8
R-金融网(www.r-gate.net)提示:您正在查看的是:分享自用金拐点主图指标 源码 通达信 贴图

自己一直在用的主图指标,买卖点一目了然,喜欢的朋友可以查看。 SHORT:=12;LONG:=26;M:=12;

DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);

DEA:=EMA(DIF,M);

MACD:=2*(DIF-DEA);

KK:=IF(DIF>DEA,5,-5);

JCSC:=(M-1)/(M+1)*DEA/(1-2/(M+1));{计算出金叉死叉时的DIFF值}

DD:=(MACD/2+(DEA*(M-1)/(M+1)))/(1-2/(M+1));{计算出明日MACD=MACD时的DIFF值}

DIF拐头价:=(DIF*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)))COLORGREEN,POINTDOT;

金死叉价:=(JCSC*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1))),NODRAW;

柱变向价:=(DD*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1))),COLORYELLOW,POINTDOT;

黄铢消失见顶:=IF(柱变向价>=DIF拐头价,柱变向价,DRAWNULL),COLORYELLOW,CIRCLEDOT,LINETHICK1;

上拐:IF(DIF拐头价<柱变向价,DIF拐头价,DRAWNULL),COLORRED,LINETHICK4;

下拐:IF(DIF拐头价>=柱变向价,DIF拐头价,DRAWNULL),COLOR33FF33,POINTDOT,LINETHICK4;

ZJ:=上拐,COLOR0000FF;

HY:=金死叉价,COLORFF00FF;

IF(ZJ>REF(ZJ,1),ZJ,DRAWNULL),COLORRED,LINETHICK2;

IF(HY>REF(HY,1),HY,DRAWNULL),COLORMAGENTA,LINETHICK2,NODRAW;

IF(HY<REF(HY,1),HY,DRAWNULL),COLORBLUE,LINETHICK2,NODRAW;

STICKLINE(C>ZJ AND C>O,H,C,0,0 ),COLORRED;

STICKLINE(C>ZJ AND C>O,L,O,0,0 ),COLORRED;

STICKLINE(C>ZJ AND C>O,O,C,2.8,1),COLORRED;

STICKLINE(C>ZJ AND C<=O,H,L,0,0 ),COLORRED;

STICKLINE(C>ZJ AND C<=O,O,C,2.8,0),COLORRED;

STICKLINE(CLOSE=ZJ,H,L,3,0),COLORWHITE;

STICKLINE(CLOSE<ZJ,H,L,0,0),COLORYELLOW;

STICKLINE(CLOSE<ZJ,O,C,2.5,0),COLORYELLOW;

STICKLINE(C<HY AND C>O,H,C,0,0),COLORCYAN;

STICKLINE(C<HY AND C>O,O,L,0,0),COLORCYAN;

STICKLINE(C<HY AND C>O,O,C,2.8,1),COLORCYAN;

STICKLINE(C<HY AND C<=O,H,L,0,0),COLORCYAN;

STICKLINE(C<HY AND C<=O,O,C,2.8,0),COLORCYAN;

HD0:=CROSS(DIF,DEA);

金收:REF(L,BARSLAST(HD0)),COLORYELLOW,DOTLINE;

LD0:=CROSS(DEA,DIF);{好股票WWW.GOODGUPIAO.COM}

死收:REF(H,BARSLAST(LD0)),COLOR00FF00,DOTLINE;

买入准备:DRAWICON(CROSS(柱变向价,DIF拐头价),上拐,34);

卖出准备:DRAWICON(CROSS(DIF拐头价,柱变向价),下拐,35);

SBL:=STRCAT(STRCAT(STRCAT(STRCAT(DYBLOCK,HYBLOCK),FGBLOCK),GNBLOCK),ZDBLOCK);

DRAWTEXT_FIX(ISLASTBAR,0.01,0.005,0,SBL),COLORCYAN;


R金融网股票学校直达:http://www.r-gate.net/xuexiao/gupiaoxuexiao/

R金融网基金学校直达:http://www.r-gate.net/xuexiao/jijinxuexiao/

R金融网外汇学校直达:http://www.r-gate.net/xuexiao/waihuixuexiao/

R金融网理财学校直达:http://www.r-gate.net/xuexiao/licaixuexiao/

R金融网保险学校直达:http://www.r-gate.net/xuexiao/baoxianxuexiao/

分享:

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.r-gate.net/xuexiao/gupiaoxuexiao/159257.html

郑重声明:R金融网发布此信息的目的在于传播更多信息,与本站立场无关。R金融网不保证该信息(包含但不限于文字、视频、音频、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。

(8)
打赏 微信扫一扫
« 上一篇 2020年06月25日 10:30:40
下一篇 » 2020年06月25日 10:30:48

最新标签