R-金融网(www.r-gate.net)分享每日股票行情和全面的金融知识!

MACD 金叉费数标注副图指标 源码 通达信 贴图 及逐次选股

R金融网 股票学校 2020-07-28 12:12:20 3
R-金融网(www.r-gate.net)提示:您正在查看的是:MACD 金叉费数标注副图指标 源码 通达信 贴图 及逐次选股


DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;


STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORBROWN;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORLIRED;

DIF升:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK1;

JCCOUNT1:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
零下金叉:CROSS(DIF,DEA) AND DIF<0.0 AND COUNT(JCCOUNT1=1,21)=1,NODRAW,COLORGREEN;
STICKLINE(零下金叉,0,DEA,0.0,0),COLORGREEN;
DRAWTEXT(零下金叉,DEA/2,' 零下一'),COLORGREEN;
零下二次:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT1=2,21)=1,NODRAW,COLORGREEN;
STICKLINE(零下二次,0,DEA,0.0,0),,COLORGREEN;
DRAWTEXT(零下二次,DEA/2,' 零下二'),COLORGREEN;
零下三次:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT1=3,21)=1,NODRAW,COLORGREEN;
STICKLINE(零下三次,0,DEA,0.0,0),COLORGREEN;
DRAWTEXT(零下三次,DEA/2,' 零下三'),COLORGREEN;
零下四次:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT1=4,21)=1,NODRAW,COLORGREEN;
STICKLINE(零下四次,0,DEA,0.0,0),,COLORGREEN;
DRAWTEXT(零下四次,DEA/2,' 零下四'),COLORGREEN;
零下五次:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT1=5,21)=1,NODRAW,COLORGREEN;
STICKLINE(零下五次,0,DEA,0.0,0),COLORGREEN;
DRAWTEXT(零下五次,DEA/2,' 零下五'),COLORGREEN;

JCCOUNT2:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA<=0));
零上金叉:CROSS(DIF,DEA) AND DIF>0.0 AND COUNT(JCCOUNT2=1,21)=1,NODRAW,COLORMAGENTA;
STICKLINE(零上金叉,0,DEA,0.0,0),COLORMAGENTA;
DRAWTEXT(零上金叉,DEA/2,'零上一 '),COLORMAGENTA;
零上二次:CROSS(DIF,DEA) AND DEA>0 AND COUNT(JCCOUNT2=2,21)=1,NODRAW,,COLORMAGENTA;
STICKLINE(零上二次,0,DEA,0.0,0),COLORMAGENTA;
DRAWTEXT(零上二次,DEA/2,' 零上二'),COLORMAGENTA;
零上三次:CROSS(DIF,DEA) AND DEA>0 AND COUNT(JCCOUNT2=3,21)=1,NODRAW,COLORMAGENTA;
STICKLINE(零上三次,0,DEA,0.0,0),COLORMAGENTA;
DRAWTEXT(零上三次,DEA/2,' 零上三'),COLORMAGENTA;
零上四次:=CROSS(DIF,DEA) AND DEA>0 AND COUNT(JCCOUNT2=4,21)=1,NODRAW,COLORMAGENTA;
STICKLINE(零上四次,0,DEA,0.0,0),COLORMAGENTA;
DRAWTEXT(零上四次,DEA/2,' 零上四'),COLORMAGENTA;
零上五次:=CROSS(DIF,DEA) AND DEA>0 AND COUNT(JCCOUNT2=5,21)=1,NODRAW,COLORMAGENTA;
STICKLINE(零上五次,0,DEA,0.0,0),COLORMAGENTA;
DRAWTEXT(零上五次,DEA/2,' 零上五'),COLORMAGENTA;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA) AND DEA<0;
STICKLINE(底背离,0,0.03,3,0),COLOR00FF00;
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK4;
DRAWTEXT(底背离,DEA,' 底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK2;
DRAWTEXT(顶背离,DEA,' 顶背离'),COLORGREEN;

DRAWTEXT(零下金叉 AND 零下二次 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;

{费数}
JC:=CROSS(DIF,DEA),NODRAW;
TJ:=SUMBARS(JC,1),NODRAW;
SC:=CROSS(DEA,DIF),NODRAW;
TS:=SUMBARS(SC,1),NODRAW;
F:=0.1;
DRAWTEXT(JC,-F,'1'),COLORMAGENTA;
DRAWTEXT(TJ=3 AND MACD>0,-F,'3'),COLORMAGENTA;
DRAWTEXT(TJ=5 AND MACD>0,-F,'5'),COLORMAGENTA;
DRAWTEXT(TJ=8 AND MACD>0,-F,'8'),COLORMAGENTA;
DRAWTEXT(TJ=13 AND MACD>0,-F,'13'),COLORMAGENTA;
DRAWTEXT(TJ=21 AND MACD>0,-F,'21'),COLORMAGENTA;
DRAWTEXT(TJ=34 AND MACD>0,-F,'34'),COLORMAGENTA;
DRAWTEXT(TJ=55 AND MACD>0,-F,'55'),COLORMAGENTA;

DRAWTEXT(SC,F,'1'),COLORGREEN;
DRAWTEXT(TS=3 AND MACD<0,F,'3'),COLORGREEN;
DRAWTEXT(TS=5 AND MACD<0,F,'5'),COLORGREEN;
DRAWTEXT(TS=8 AND MACD<0,F,'8'),COLORGREEN;
DRAWTEXT(TS=13 AND MACD<0,F,'13'),COLORGREEN;
DRAWTEXT(TS=21 AND MACD<0,F,'21'),COLORGREEN;
DRAWTEXT(TS=34 AND MACD<0,F,'34'),COLORGREEN;
DRAWTEXT(TS=55 AND MACD<0,F,'55'),COLORGREEN;


R金融网股票学校直达:http://www.r-gate.net/xuexiao/gupiaoxuexiao/

R金融网基金学校直达:http://www.r-gate.net/xuexiao/jijinxuexiao/

R金融网外汇学校直达:http://www.r-gate.net/xuexiao/waihuixuexiao/

R金融网理财学校直达:http://www.r-gate.net/xuexiao/licaixuexiao/

R金融网保险学校直达:http://www.r-gate.net/xuexiao/baoxianxuexiao/

分享:

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.r-gate.net/xuexiao/gupiaoxuexiao/180197.html

郑重声明:R金融网发布此信息的目的在于传播更多信息,与本站立场无关。R金融网不保证该信息(包含但不限于文字、视频、音频、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。

  MACD 金叉费数标注副图指标 源码 通达信 贴图 及逐次选股   通达信公式下载   股票公式  

(3)
打赏 微信扫一扫
« 上一篇 2020年07月28日 12:12:19
下一篇 » 2020年07月28日 12:12:24

MACD 金叉费数标注副图指标 源码 通达信 贴图 及逐次选股_相关内容