R-金融网(www.r-gate.net)分享每日股票行情和全面的金融知识!

唐能通主图/选股指标源码 通达信 贴图

R金融网 股票学校 2020-07-31 10:30:58 4
R-金融网(www.r-gate.net)提示:您正在查看的是:唐能通主图/选股指标源码 通达信 贴图

{唐能通主图}
DRAWBAND(MA(C,20),RGB(90,0,0),MA(C,60),RGB(0,90,0));{牛熊变线}

变线:=EMA(MA(CLOSE,20),5),LINETHICK0;
STICKLINE(C>=变线 AND C>=O,H,L,0,0),COLORRED;
STICKLINE(C>=变线 AND C>=O,C,O,2.7,1),COLORRED;
STICKLINE(C>变线 AND C<=O,H,L,0,1),COLORCYAN;
STICKLINE(C>变线 AND C<=O,C,O,3,0),COLORCYAN;
STICKLINE(C<变线 AND C<=O,H,L,0,1),COLORCYAN;
STICKLINE(C<变线 AND C<=O,C,O,3,0),COLORCYAN;
STICKLINE(C<变线 AND C<=O,H,L,0,1),COLORGREEN;
STICKLINE(C<变线 AND C>O,H,L,0,1),COLORRED;
STICKLINE(C<变线 AND C>O,C,O,3,1),COLORGRAY;
STICKLINE(C<变线 AND C<=O,C,O,3,0),COLORGRAY;
PM:MA(C,5),COLORWHITE,LINETHICK1;
IF(PM<REF(PM,1),PM,DRAWNULL),COLORGREEN,POINTDOT;
IF(PM>=REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
A:=MA(CLOSE,12)+ABS(MA(CLOSE,12)-REF(MA(CLOSE,12),1));
B:=MA(CLOSE,12)+MA(CLOSE,12)-REF(MA(CLOSE,12),1);

分水岭:=IF(MA(CLOSE,12)<B,B,MA(CLOSE,12));
操作线:=分水岭-(EMA(C,3)-分水岭),COLORLIRED,LINETHICK2,DOTLINE;

AA:=CROSS(分水岭,操作线);
STICKLINE(AA,C,O,3,0),COLOR0000AA;
STICKLINE(AA,C,O,2,0),COLOR0033CC;
STICKLINE(AA,C,O,1,0),COLOR0055EE;
STICKLINE(AA,C,O,0.3,0),COLOR0099FF;
STICKLINE(AA,H,L,0,1),COLOR0099FF;
RR:=CROSS((MA(VOL,5)),(MA(VOL,10))) AND MA(C,2)>=MA(C,4);
STICKLINE(RR,C,O,3,0),COLOR0000AA;
STICKLINE(RR,C,O,2,0),COLOR0033CC;
STICKLINE(RR,C,O,1,0),COLOR0055EE;
STICKLINE(RR,C,O,0.3,0),COLOR0099EE;
STICKLINE(RR,H,L,0,1),COLOR0099FF;
MA5:MA(CLOSE,5),NODRAW;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA,LINETHICK2;
MA60:MA(CLOSE,60),COLORGREEN,LINETHICK2;
MA120:MA(C,120),COLORRED;
DRAWTEXT(CROSS(MA20,MA60),MA20,'牛'),COLORYELLOW,LINETHICK4;
DRAWTEXT(CROSS(MA60,MA20),MA20,'熊'),COLORWHITE,LINETHICK2;
{唐能通主图AAA}
{突破买入}
N1:=5;
N2:=7;
N3:=11;
EM1:=EMA(C,N1),COLORWHITE;
EM2:=EMA(C,N2),COLORRED;
EM3:=EMA(C,N3),COLORGREEN;

TJ:=BETWEEN(EM2,EM1,EM3);
IF(MA(C,20)>REF(MA(C,20),1),MA(C,20),DRAWNULL)COLORRED,LINETHICK3;
立桩量:=FILTER(TJ=0,5);
价:REF(H,BARSLAST(立桩量)),NODRAW;
STICKLINE(C,REF(H,BARSLAST(立桩量)),REF(H,BARSLAST(立桩量)),6,0),COLORGREEN;
DRAWTEXT(C AND ISLASTBAR,价,'突破买入(立桩量价)'),COLORMAGENTA,DRAWABOVE;

{倍量 AND 突破前高}
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
倍量:=VOL/REF(VOL,1)>=1.9;
突破前高:=CROSS(C,前高);
DRAWICON(倍量 AND 突破前高,L*0.99,34);


月价托:=MA5>MA20 AND MA20>MA60 AND MA60>MA120 AND MA5>MA20 AND CROSS(MA10,MA20);
月蜘蛛:=MA5>MA10 AND MA10>MA20 AND CROSS(MA5,MA20)AND CROSS(MA10,MA20);
死蜘蛛:=MA5<MA10 AND MA10<MA20 AND CROSS(MA20,MA5)AND CROSS(MA20,MA10);
DRAWTEXT(月蜘蛛,MA20-0.08,'金蜘蛛'),COLORMAGENTA;
DRAWTEXT(死蜘蛛,MA20+0.20,'死蜘蛛'),COLORGREEN;

DRAWTEXT(月价托 ,MA20-0.12,'月价托'),COLORYELLOW;
AA1:=BARSLAST(MA60>MA20 AND (MA20=MA10 OR MA20>MA10));
BB1:=REF(COUNT(C<MA60,AA1)=AA1,1);
CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB AND CC1,COLOR00FF00;
DRAWTEXT(芙蓉出水,H+0.12,'芙蓉出水'),COLORFF00FF;
STICKLINE(芙蓉出水,H,L,0.5,1),COLORFF00FF;
STICKLINE(芙蓉出水,O,C,3,1),LINETHICK2,COLORFF00FF;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
ZJ:=AMOUNT/10000;
TM:=V-MA(V,10);


{压力一阳线高}
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HHD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LLD:=FILTER(C2,10);
前期高位:REF(C,BARSLAST(HHD)),COLOR00FF00,POINTDOT;{前期阳线实顶线}
STICKLINE(C,前期高位,前期高位,8,0),COLORYELLOW;
DRAWTEXT(前期高位 AND ISLASTBAR,前期高位,'前期阳线实顶'),COLORYELLOW,DRAWABOVE;


R金融网股票学校直达:http://www.r-gate.net/xuexiao/gupiaoxuexiao/

R金融网基金学校直达:http://www.r-gate.net/xuexiao/jijinxuexiao/

R金融网外汇学校直达:http://www.r-gate.net/xuexiao/waihuixuexiao/

R金融网理财学校直达:http://www.r-gate.net/xuexiao/licaixuexiao/

R金融网保险学校直达:http://www.r-gate.net/xuexiao/baoxianxuexiao/

分享:

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.r-gate.net/xuexiao/gupiaoxuexiao/182899.html

郑重声明:R金融网发布此信息的目的在于传播更多信息,与本站立场无关。R金融网不保证该信息(包含但不限于文字、视频、音频、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。

  唐能通主图/选股指标源码 通达信 贴图   通达信公式下载   股票公式  

(4)
打赏 微信扫一扫
« 上一篇 2020年07月31日 10:26:04
下一篇 » 2020年07月31日 10:31:07

唐能通主图/选股指标源码 通达信 贴图_相关内容