R-金融网(www.r-gate.net)分享每日股票行情和全面的金融知识!

通达信绿山红帆看山水如画副图指标 源码 贴图

R金融网 股票学校 2019-12-13 09:50:32 38
R-金融网(www.r-gate.net)提示:您正在查看的是:通达信绿山红帆看山水如画副图指标 源码 贴图


DI:=EMA(C,3)-EMA(C,13);
DE:=EMA(DI,9);
MACD1:=2*(DI-DE)*10;
DI2:=EMA(C,5)-EMA(C,26);
DEA2:=EMA(DI2,9);
MACD2:=2*(DI2-DEA2)*10;
DIFF3:=EMA(C,7)-EMA(C,89);
DEA3:=EMA(DIFF3,21);
MACD3:=2*(DIFF3-DEA3)*10;
MMACD5:=MA(MACD3,3);
M3:=IF(MACD3<0,-MACD3,DRAWNULL)LINETHICK4,COLOR646400;
M2:=IF(MACD2<0,-MACD2,DRAWNULL)LINETHICK4,COLOR333333;
M1:=IF(MACD1<0,-MACD1,DRAWNULL);
MM3:=IF(MACD3>0,MACD3,DRAWNULL);
MN1:=HHV(MM3,250);
MN2:=HHV(M3,250);
MMM:=CONST(MAX(MN1,MN2));
DRAWBAND(MMM,RGB(50,80,50),-MMM,DRAWNULL);
DRAWBAND(MMM,RGB(150,150,150),0,DRAWNULL);
DRAWBAND(M3,RGB(00,100,100),0,DRAWNULL);
DRAWBAND(M2,RGB(100,100,100),0,DRAWNULL);
DRAWBAND(M1,RGB(80,80,00),0,DRAWNULL);
DRAWBAND(MM3,RGB(0,200,0),0,DRAWNULL);
STICKLINE(MACD2>=0,0,MACD2,4,0),COLOR009900;
STICKLINE(MACD1>=0,0,MACD1,4,0),COLOR006600;
MM:=-M3*0.3;
DRAWBAND(0,RGB(0,0,0),-MM3*0.3,DRAWNULL);
DRAWBAND(0,RGB(0,0,0),MM,DRAWNULL);
IF(MACD3>0,-3,DRAWNULL),COLORFFFF00,POINTDOT;
IF(C>0,-2,-2),COLORFFFF00,POINTDOT;
小花:IF(MACD1>=0 AND REF(MACD1,1)<0,1,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF33FF;
IF(MACD1>=0 AND REF(MACD1,1)<0,1,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;
红帆:STICKLINE(CROSS(MACD3,MMACD5) AND MACD3<0,MACD3*1.1,MACD3*1.1-0.5,16,0),COLOR3366CC;
STICKLINE(CROSS(MACD3,MMACD5) AND MACD3<0,MACD3*1.1+4,MACD3*1.1+0.3,5,0),COLOR0000FF;
春雪:IF(CROSS(MMACD5,MACD3) AND MACD3>0,MACD3*1.2,DRAWNULL),CROSSDOT, LINETHICK2,COLORFFFFFF;
IF(CROSS(MMACD5,MACD3) AND MACD3<0,MACD3*0.8,DRAWNULL),CROSSDOT, LINETHICK2,COLORCCCCCC;


R金融网股票学校直达:http://www.r-gate.net/xuexiao/gupiaoxuexiao/

R金融网基金学校直达:http://www.r-gate.net/xuexiao/jijinxuexiao/

R金融网外汇学校直达:http://www.r-gate.net/xuexiao/waihuixuexiao/

R金融网理财学校直达:http://www.r-gate.net/xuexiao/licaixuexiao/

R金融网保险学校直达:http://www.r-gate.net/xuexiao/baoxianxuexiao/

分享:

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.r-gate.net/xuexiao/gupiaoxuexiao/20864.html

郑重声明:R金融网发布此信息的目的在于传播更多信息,与本站立场无关。R金融网不保证该信息(包含但不限于文字、视频、音频、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。

(38)
打赏 微信扫一扫
« 上一篇 2019年12月13日 09:50:29
下一篇 » 2019年12月13日 09:50:34